GImageX

©2007-2018 Jonathan Bennett

GImageX Homepage

Contact

Introduction

GImageX is a graphical user interface for the ImageX tool from the Windows Assessment and Deployment Kit (Windows ADK). ImageX is used to capture and apply WIM images for Windows deployments.

GImageX is a native application for the x86 and x64 platforms (Windows XP or later) that will also work in Windows PE (WinPE).

Note: GImageX uses the Microsoft supported WIMGAPI API interface for working with WIM images.


License

Software License

GImageX v2

Author : Jonathan Bennett

WWW : https://www.autoitconsulting.com/site/software/gimagex/

Contact : https://www.autoitconsulting.com/site/about/contact-us/

________________________________________________________

END-USER LICENSE AGREEMENT FOR THIS SOFTWARE

Important - read carefully:

This End-User License Agreement ("EULA") is a legal agreement between you (either an individual or a single entity) and the mentioned author of this Software for the software product identified above, which includes computer software and may include associated media, printed materials, and "online" or electronic documentation ("SOFTWARE PRODUCT"). By installing, copying, or otherwise using the SOFTWARE PRODUCT, you agree to be bound by the terms of this EULA. If you do not agree to the terms of this EULA, do not install or use the SOFTWARE PRODUCT.

SOFTWARE PRODUCT LICENSE

The SOFTWARE PRODUCT is protected by copyright laws and international copyright treaties, as well as other intellectual property laws and treaties. The SOFTWARE PRODUCT is licensed, not sold.

1. GRANT OF LICENSE

This EULA grants you the following rights:

Installation and Use. You may install and use an unlimited number of copies of the SOFTWARE PRODUCT.

Reproduction and Distribution. You may reproduce and distribute an unlimited number of copies of the SOFTWARE PRODUCT either in whole or in part; each copy should include all copyright and trademark notices, and shall be accompanied by a copy of this EULA. Copies of the SOFTWARE PRODUCT may be distributed as a standalone product or included with your own product.

2. COPYRIGHT

All title and copyrights in and to the SOFTWARE PRODUCT (including but not limited to any images, photographs, animations, video, audio, music, text, and "applets" incorporated into the SOFTWARE PRODUCT), the accompanying printed materials, and any copies of the SOFTWARE PRODUCT are owned by the Author of this Software. The SOFTWARE PRODUCT is protected by copyright laws and international treaty provisions. Therefore, you must treat the SOFTWARE PRODUCT like any other copyrighted material.

MISCELLANEOUS

If you acquired this product in the United Kingdom, this EULA is governed by the laws of the United Kingdom.

If this product was acquired outside the United Kingdom, then local law may apply.

Should you have any questions concerning this EULA, or if you desire to contact the author of this Software for any reason, please contact him/her at the email address mentioned at the top of this EULA.

LIMITED WARRANTY

NO WARRANTIES

The Author of this Software expressly disclaims any warranty for the SOFTWARE PRODUCT. The SOFTWARE PRODUCT and any related documentation is provided "as is" without warranty of any kind, either express or implied, including, without limitation, the implied warranties or merchantability, fitness for a particular purpose, or non-infringement. The entire risk arising out of use or performance of the SOFTWARE PRODUCT remains with you.

NO LIABILITY FOR DAMAGES

In no event shall the author of this Software be liable for any damages whatsoever (including, without limitation, damages for loss of business profits, business interruption, loss of business information, or any other pecuniary loss) arising out of the use of or inability to use this product, even if the Author of this Software has been advised of the possibility of such damages. Because some states/jurisdictions do not allow the exclusion or limitation of liability for consequential or incidental damages, the above limitation may not apply to you.


GImageX Installation

If running Windows 7 or later, or if the full Windows Assessment and Deployment Kit (Windows ADK) has been installed on a machine then you can simply run gimagex.exe directly. Be sure to choose the correct x86 or x64 version of GImageX depending on your operating system architecture.

If the Windows ADK has not been installed, or you wish to use GImageX from something like Windows XP then you still need to get hold of the WIMGAPI DLLs from the Windows ADK installation. Unfortunately I am not able to distribute these DLLs myself so you will have to extract them manually from the Windows ADK as follows:

Note: Only the Deployment Tools part of the Windows ADK is required to get access to the required DLLs for GImageX. You don't need to download the whole thing.

1. Find a machine that has the Windows ADK installed (in this example we will assume that it is the 8.1, earlier versions have slightly different folders).

2. Using explorer browse to C:\Program Files (x86)\Windows Kits\8.1\Assessment and Deployment Kit\Deployment Tools\x86\DISM folder.

3. You must get the correct version of files for your operating system. If you want to use GImageX in a 64bit environment then browse to the amd64\DISM folder.

4. Copy the following files into the same folder as gimagex.exe:

  • wimgapi.dll
  • wimmount.sys
  • wimmountadksetupx86.exe
  • wimprovider.dll
  • wimserv.exe

5. Your GImageX installation folder should now look like this (x86 version shown):

You should now be able to run gimagex.exe from this installation folder to capture and apply WIM files. If you also wish to be able to mount WIM files then you may (depending on your OS) need to also install the wimmount.sys driver by running wimmountadksetupx86.exe.


Capture

WIM

Option | Description
Source | The source folder to capture.
Destination | The destination WIM to capture to.
Compression | Compression type.
Name | The name of the image.
Description | The description of the image.
Display Name | The display name of the image. (As shown in Windows Setup to differentiate between images).
Display Description | The display description of the image. (As shown in Windows Setup to differentiate between images).
SKU Flag | The SKU flag to use for Windows Setup. In most cases when capturing the flag will be determined automatically.

Options

Option | Description
Config.ini | An imagex formatted wimscript.ini file. (Only exclusions are supported).
Boot | Make the capture image the boot image.
Verify | Verify each file captured.
Check | Adds integrity check information to the WIM file.
Show exclusions and Config.ini in output | Shows the Config.ini file list of exclusions in the log output.
Temp Folder | An optional temp folder. By default GImageX uses the same logic as ImageX for automatically determining a temp folder. Do not use the WinPE RAM disk as the temp folder - it is not large enough.


Apply

WIM

Option | Description
Source | The source WIM to apply.
Destination | The destination folder to apply to.
Image | The image index.

Options

Option | Description
Verify | Verify each file applied.
Check | Verifies integrity check information of the WIM file.


Info

WIM

Option | Description
Source | The source WIM to get information about.


Change

WIM

Option | Description
Source | The source WIM to change.
Image | The image index to change.

New Information

Option | Description
Name | The name of the image.
Description | The description of the image.
Display Name | The display name of the image. (As shown in Windows Setup to differentiate between images).
Display Description | The display description of the image. (As shown in Windows Setup to differentiate between images).
SKU Flag | The SKU flag to use for Windows Setup.
Boot | Make this the bootable image in the WIM.

Options

Option | Description
Check | Adds integrity check information to the WIM file.


Mount

Mount

Option | Description
Mount Point | The folder to mount the image into (the folder must already exist).
Source | The source WIM to mount.
Image | The image index.
Read and White | The mounted image will be writable - if this is not checked the image is read-only.

Unmount

Option | Description
Commit Changes | Save any changes to the WIM when unmounting. If this is not checked then any changes made will be lost. Note: The image must have been mounted with the "Read and Write" option for this to have any effect.


Delete

WIM

Option | Description
Source | The source WIM to delete.
Image | The image index to delete.

Options

Option | Description
Check | Adds integrity check information to the WIM file.


Export

Source WIM

Option | Description
Source | The source WIM to export.
Image | The image index to export.

Destination WIM

Option | Description
Destination | The destination WIM to export to.
Compression | Compression type.
Name | The name of the image.
Boot | The exported image should be bootable.

Options

Option | Description
Check | Adds integrity check information to the exported WIM file.


Split

Export

Source WIM

Option | Description
Source | The source WIM to export.

Destination SWM

Option | Description
Destination | The destination WIM to export to.
Split Size | Use FAT32 to allow image to fit on a UEFI FAT32 partition.

Options

Option | Description
Check | Checks integrity information when reading existing WIM.


History

Here is the public history for GImageX.

13th June 2018 - v2.2.0

GImageX:

  • Recompiled and tested against Windows 10 1803 ADK. GimageX is tested against Windows 7 and Windows 10.
  • Mount and Unmount operations now show progress.
  • Added Split WIM support.
  • Fixed mouse cursor busy / arrow issues.

GImageX COM:

  • Removed COM interface - no-one using.

22nd January 2014 - v2.1.1

GImageX:

  • Removed spurious INFO messages with Err=282. These are just warnings that extended attributes are not captured. This is how DISM works but it suppresses the messages. The messages were causing confusion.
  • Error and warning messages now provide the string description rather than an error code.

GImageX COM:

  • Updated to work with the Windows 8.1 and Windows ADK 8.1 versions.

Note: Please use this version of GImageX with the Windows ADK for Windows 8.1.

21st November 2013 - v2.1.0

GImageX:

  • Updated to work with the Windows 8.1 and Windows ADK 8.1 versions.

GImageX COM:

  • Updated to work with the Windows 8.1 and Windows ADK 8.1 versions.

Note: Please use this version of GImageX with the Windows ADK for Windows 8.1.

19th September 2009 - v2.0.17

GImageX:

  • Updated to work with the Windows 7 and WAIK 2.0 RTM versions.

GImageX COM:

  • Updated to work with the Windows 7 and WAIK 2.0 RTM versions.

Note: Please use this version of GImageX with the Windows AIK for Windows 7.

11th May 2009 - v2.0.16 BETA

GImageX:

  • Updated to work with the Windows 7 and WAIK 2.0 RC versions.

GImageX COM:

  • Updated to work with the Windows 7 and WAIK 2.0 RC versions.

Note: Please only use this beta version of GImageX with WAIK 2.0 beta.

3rd February 2009 - v2.0.15 BETA

GImageX:

  • Updated to work with the Windows 7 and WAIK 2.0 BETA versions.
  • Mount operations now use the progress dialog as mounting from the network or USB could sometimes take a while and it would look like GImageX had crashed.
  • Added support for the NORPFIX image capture option.

GImageX COM:

  • Updated to work with the Windows 7 and WAIK 2.0 BETA versions.

2nd October 2008 - v2.0.14

  • Added the ability to add/change DisplayName and DisplayDescription XML tags. These determine how images are displayed within Windows Setup.

4th July 2008 - v2.0.13

GImageX:

  • Captures are now correctly generating the <WINDOWS> XML tags.

GImageX COM:

  • Captures are now correctly generating the <WINDOWS> XML tags.

26th March 2008 - v2.0.12

GImageX:

  • Compiled against the latest WAIK 1.1 to ensure compatibility.

GImageX COM:

  • Compiled against the latest WAIK 1.1 to ensure compatibility.

20th Jan 2008 - v2.0.11

GImageX:

  • No changes.

GImageX COM:

  • Due to troubles in HTAs, renamed the properties: Image to ImageIndex, and Name to ImageName.

1st Jan 2008 - v2.0.10 BETA

GImageX:

  • No changes.

GImageX COM:

  • Allowed WScript.ConnectObject type operations to work.

27th Dec 2007 - v2.0.9 BETA

GImageX:

  • No changes.

GImageX COM:

  • Fixed MSVC runtime dependency - really!

21st Dec 2007 - v2.0.8 BETA

GImageX:

  • No changes.

GImageX COM:

  • Added methods: GetOpenFileName, GetSaveFileName
  • Added methods: GetWIMInfo, GetImageInfo

20th Dec 2007 - v2.0.7 BETA

GImageX:

  • No changes.

GImageX COM:

  • COM component no longer need Visual Studio runtimes installed. Oops!

17th Dec 2007 - v2.0.6 BETA

GImageX:

  • No changes.

GImageX COM:

  • Added a COM component for use in VBScript/other applications, currently just Capture/Append/Apply are implemented - testing appreciated.

15th Dec 2007 - v2.0.5 BETA

  • Image selection screen was not working properly when an image did not contain both a name and description

2nd Dec 2007 - v2.0.4 BETA

  • Improved mount/unmount interface.

2nd Dec 2007 - v2.0.3 BETA

  • Improved image selection interface.

1st Dec 2007 - v2.0.2 BETA

  • Added Delete tab.
  • Added Export tab.
  • Some internal improvements to XML handling.

16th Oct 2007 - v2.0.0 BETA

  • Added Change tab
  • Added Mount tab
  • Fixed bug with Capture+verify (wasn't verifying).
  • Check option added to Apply.
  • Automatic temp folder chosen during capture now consistent with imagex.exe

15th Oct 2007 - v2 ALPHA

  • Added /check options.
  • Supports a wimscript.ini config file for exclusions.
  • Allows manual setting of the temporary directory for capture.

12th Oct 2007 - v2 ALPHA

  • Initial native C++ Version using the WIM API directly.

2006 - GImageX v1 (AutoIt wrapper)


Windows Assessment and Deployment Kit (Windows ADK)

Windows Assessment and Deployment Kit (Windows ADK) is a set of tools and documentation that support the configuration and deployment of Microsoft® Windows® operating systems.. By using Windows ADK, you can automate Windows installations, capture Windows images with ImageX, configure and modify images using Deployment Imaging Servicing and Management (DISM), create Windows PE images, and migrate user profiles and data with the User State Migration Tool (USMT).

This version of GImageX has been compiled against the Windows 10 1803 version of the Windows ADK. The Windows ADK can be downloaded here. When installing, you only need to select the Deployment Tools part to get the DLLs that GImageX required.

Note: This version of GImageX should also work correctly with the built in versions of the WIMGAPI included with Windows 7 and later. When using Windows XP you will need to install the ADK or include the relevant DLLs (See installaton).